Veelkord aegunud PHP versioonidest

Kaarel Urva
Jaga:

Mäletatavasti teavitasime aprilli lõpus kliente sellest, et aegunud PHP versioonide kasutamine muutub tasuliseks. Mõistetavasti tuli see uudis paljudele üllatusena, mistõttu on oluline siiski taaskord märkida, et need PHP versioonid on aegunud olnud juba aastaid ning nende aastate jooksul oleme sellest oma kasutajaid ka korduvalt teavitanud. Ülemineku lihtsustamiseks uuematele PHP versioonidele oleme ära teinud väga suure töö. Kuna kordamine on tarkuse ema, siis käime selle teema veelkord üle.

Veelkord aegunud PHP versioonidest

Aegunud PHP versioonide tasuliseks muutmine pole meie klientidele midagi uut. Viimased PHP 5.4 (ja vanemad) versioone toetavad serverid kaotasime 2022. aasta lõpus, mil lõpetasime toe selleks ajaks juba väga vanadele versioonidele. Sellest ajast alates on Minu Zone kasutajaliideses saadaval ainulaadne PHP versiooni testimise tööriist, mis tänaseks on omakorda läbinud põhjaliku uuenduse ja mis võimaldab testida kõiki Zone poolt toetatud PHP versioone. Loe selle kohta siit lähemalt: Vähem peavalu uute PHP versioonidega.

Uut PHP strateegiat välja töötades oleme pannud palju rõhku kasutajamugavusele. Esimese asjana oleme ise uuendanud umbes 2/3 kõigist aegunud PHP versioonidest, mis Zone veebimajutusplatvormil 1. aprilli seisuga olid. Suurima panuse on andnud:

  • Alam- ja peadomeenid, kus PHP-d pole kasutusel
  • Tuhanded WordPressi baasil kodulehed, mis töötasid vähemalt PHP 8.0 versiooniga
  • Alam- ja peadomeenid, mis on suunatud Zone veebist eemale erinevatel põhjustel
  • Lisaks on lõppkasutajad ise tuhandeid hoste iseseisvalt ära uuendanud – te olete väga tublid!

Nagu legendaarne Ameerika TV müügimees Billy Mays kunagi ütles, siis: “But wait! There’s more!”

PHP uuendamine pole sageli kasutajate to-do nimekirjas esimesel kohal. Kui versiooni uuendamine ette võetakse, siis tehakse seda üks kord ja jäetakse see uuesti unarusse. Soovime pakkuda jätkusuutlikku teenust ja muuta klientide elu lihtsamaks. Seetõttu töötasime välja progressiivse PHP toe, mille kohta leiad täpsemat infot sellest blogiartiklist: PHP versiooniuuenduste strateegiad.

Nimelt saab nüüd iga kasutaja või veebilehe tegija valida strateegia, mille alusel tema veebiserveri PHP versiooni automaatselt uuendatakse. Teavitame sind uutest PHP versioonide tulekust ja ka uutele versioonidele üleminekust aegsasti ette.

Mida aeg edasi, seda nutikamaid valikuid PHP versiooni strateegiate alla tekib. Edaspidi ei pea enamus meie kasutajatest oma PHP versiooni pärast muretsema. Samuti on valmimas teavitussüsteem neile, kes automaatset PHP versiooni uuendust ei soovi. Saadame tulevikus kasutajatele ka infot uutest PHP versioonidest, et aegunud versioonide saabumine ei tuleks üllatusena.

Lõpetuseks soovime tänada kõiki meie koostööpartnereid ja aktiivseid arendajaid, kes on aidanud klientide PHP versioone uuendada. Loetelu Zone koostööpartneritest, kes sellistes töödes aidata saab, leiad siit: Zone koostööpartnerid.

Küsimuste korral võta kindlasti ühendust Zone klienditoega. Näiteks lihtsamad WordPressi veebilehed on võimalik lahendada isegi meie esmaklassilise klienditoe poolt – impordime WordPressi Zone+ alla, teeme testimiseks staging lehe ning üldjuhul suudame pluginate ja WordPressi versiooni uuendamise järel ka PHP ära värskendada. Selleks võta meiega julgesti ühendust! 🙂

Populaarsed postitused

Veelkord aegunud PHP versioonidest

Kaarel Urva
Mäletatavasti teavitasime aprilli lõpus kliente sellest, et aegunud PHP versioonide kasutamine muutub tasuliseks. Mõistetavasti tuli see uudis paljudele...

Peagi saabub WooCommerce 9.0

Ingmar Aasoja
Kui räägime veebilehtedest, siis mõtleme sageli WordPressile. Kui lisame jutule e-poe, siis enamasti räägime WooCommerce'ist. WooCommerce on paljude...

PHP versiooniuuenduste strateegiad

Ingmar Aasoja
See, et aegunud PHP on koormaks nii meile kui ka klientidele, on korduvalt läbikäidud teema. Seetõttu oleme ette võtnud teekonna, millega püüame...

BIMI ja DMARC ei pruugi päästa: Tähelepanuta jäänud DKIM haavatavus

blogi
Zone spetsialistid märkasid DKIM standardis olevate hoiatuste ignoreerimisest tulenenud haavatavust, mis mõjutab kogu e-posti ökosüsteemi ja paneb...